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About this guide 

This document describes features introduced in Infor VISUAL 9.0.0. For information about features 
introduced in earlier versions of VISUAL, consult the release notes for that version. For example, if 
you are upgrading from VISUAL 7.1.0 to VISUAL 9.0.0, consult the release notes for VISUAL 7.1.1, 
VISUAL 7.1.2, and VISUAL 8.0.0 for important information about the features introduced in those 
releases.  

You can find release notes on Infor Xtreme. 

Intended audience 
This document is intended for any VISUAL user. 

Related documents 
You can find the documents in the product documentation section of the Infor Xtreme Support portal, 
as described in "Contacting Infor" on page 9. 

Infor VISUAL 9.0.0 Hardware Guidelines 

Infor VISUAL 9.0.0 Software Compatibility 

Infor VISUAL 9.0.0 Applications Installation Guide 

Infor VISUAL 9.0.0 Database Installation Guide for Oracle 

Infor VISUAL 9.0.0 Database Installation Guide for SQL Server 

Contacting Infor 
If you have questions about Infor products, go to the Infor Xtreme Support portal. 
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If we update this document after the product release, we will post the new version on this Web site. 
We recommend that you check this Web site periodically for updated documentation.  

If you have comments about Infor documentation, contact documentation@infor.com. 

 

mailto:documentation@infor.com
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Chapter 1 Prerequisites 1  
 

 

This section lists the software required to use Infor VISUAL as of the publication date of this 
document. For up-to-date information, see the Infor VISUAL 9.0.0 Compatibility Matrix.  

This software is required to use Infor VISUAL 9.0.0: 

Database engine. You must use one of these database engines: 

• SQLServer 2008 R2 
• SQLServer 2012 and 2012 R2 
• SQLServer 2014 
• SQLServer 2016 
• Oracle 11g 
• Oracle 12c 

Server operating system. You must use one of these server operating systems: 

• Windows 2008 32-bit with Oracle 11g or SQL Server 2008 R2. Windows 2008 64-bit with Oracle 
11g, Oracle 12c, or SQL Server 2008 R2. 

• Windows 2008 R2 64-bit with any of the above database engines 
• Windows 2012 and 2012 R2 with any of the above database engines 

Client operating system. Your clients must use one of these operating systems: 

• Windows 7 SP1 
• Windows 8 
• Windows 8.1 
• Windows 10 

Gupta runtime requirements 
VISUAL 9.0.0 requires the use of the Gupta 7.0 Update 1 runtime. Previous versions of the Gupta 
runtime are not compatible with VISUAL 9.0.0.  

Infor strongly recommends removing all previous versions of the Gupta runtime before installing 
VISUAL 9.0.0. 
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Infor strongly recommends that you do not use multiple versions of the Gupta runtimes on the same 
client.
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Chapter 2 Overview 2  
 

 

This release introduces over 50 enhancements and improvements in a variety of areas in VISUAL. 

Videos that demonstrate many of these enhancements are available in a directory with your VISUAL 
executables.  

Core business features 
VISUAL 9.0.0 offers many enhancements that are designed to streamline your day-to-day 
operations. These features include: 

• Notifications and email. You can now set up VISUAL to automatically email internal and 
external contacts when a business event occurs, such as an update to a purchase order or the 
receipt of a payment. In addition, you can now use email clients such as Gmail and Thunderbird 
to send and receive email from VISUAL. 

• Document attachment management. You can now set up different directories for document 
attachments by site and by document reference type. 

• Audit History dialog, User Toolbar changes, and other core business features. The Audit 
History dialog is available in several areas of VISUAL. You can use this dialog to track audited 
changes to a particular document. You can now set up your User Toolbar to launch a website or 
run a query from the Query Tool. In addition, several other features have been introduced, 
including the use of ISO country codes in addresses, the ability recalculate proration after editing 
overlapping labor tickets, an extension of the length of the Part Description field, and the 
standardization of table configuration.  

Analytics and business intelligence 
VISUAL 9.0.0 introduces more methods for you to use to analyze your business. These features are: 

• Leadtime Lifecycle. You can use the new Leadtime Lifecycle feature to set benchmarks for 
your sales cycle and to measure your actual performance against the benchmarks.  
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• User-defined Dashboard Metrics. With User-defined Dashboard metrics, you can design your 
own analytics and detail grids based on any table or custom view in your database.  

Scheduling and Throughput 
In the Throughput Window, several changes have been made to improve the accuracy of the 
analysis. You can also use the new soft allocations audit dialogs and soft allocations report to gain 
insight into how VISUAL is matching supply to demand. You can also view unallocated orders in the 
Customer Service Impact Detail analysis. 

In the Concurrent Scheduler, you can now set up scheduling preferences at the tenant, site, and 
schedule levels. 

Shop Floor 
The Shop Floor app has been expanded to include labor reporting and inventory transactions.  

Material Planning 
Several enhancements have been made to the Advanced mode of the Material Planning window to 
make calculations of nettable quantity and suggested MPS more predictable. You can now also view 
a breakdown of each supply period by day. You can apply the color coding that you set up for the 
Standard mode to the Advanced mode.  

Utilities and administration 
The DBR scheduler can now be run with VISUAL AutoRun. In MRP AutoRun, you can now schedule 
the net change MRP run separately from the regeneration run. When you set up the schedule for 
MRP AutoRun and the Scheduler AutoRun, you can now ensure that the two services do not run at 
the same time.  

Other improvements include changes to the Query Tool to make writing queries easier. In addition, 
the User dialog in Security Maintenance has been redesigned, and the SYSADM user can more 
easily set up global preferences in Preferences Maintenance. 
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Sales 
These enhancements have been made to Sales functionality: 

• Quick Quote and Estimating enhancements. You can now develop a Quick Quote in an Excel 
spreadsheet and then import it into the Quick Quote window. In addition, you can set up bid 
rates for parts and resources that you can use in your quick quotes. In the Estimating Window, 
you can use preferred vendor pricing when you are creating a quote from a part.  

• RMA enhancements. The RMA process is now more flexible and streamlined. You have a 
range of options when a customer makes a return: you can choose to credit or send a 
replacement to a different customer, you can reorder RMA lines, and you can reuse or copy the 
evaluation work order the repair work order. To streamline the RMA process, you can suppress 
the dialogs that are displayed during RMA processing. To increase the accuracy of the return 
process, you can now pre-assign returns to the appropriate supply work orders.  

• Other sales enhancements. You can now email AR invoices in a batch rather than one-by-one. 
In Customer Order Entry and the Order Management Window, a new Sales Order Gross Profit 
View Panel shows you the anticipated profit for the entire sales order. In Price Book, a new Price 
Group context has been introduced.  

Procurement enhancements 
Drill-down buttons have been added to the Receiving Inspection window. In Outside Service 
Maintenance, you can now create customizable user-defined fields.  

Accounting enhancements 
In the Accounting Window, you can create account groups. You can use account groups to track 
performance of specific areas of your business. 

In Accounting Entity Maintenance, you can set up a preference to create single-document batches 
when you post to the General Ledger. If your accounting entity is VAT-enabled, you can create 
specific Euro-VAT codes for transactions that you conduct within the Euro zone.  

In Costing Utilities, you can export the contents of the Recalculate Standard Costs table to Microsoft 
Excel.  
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Enhancements for VISUAL for .NET users  
In many cases, VISUAL now writes directly to your .NET databases instead of sending information 
via the Exchange service. Documents from .NET are now shown on the Document Lifecycle viewer.  
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Chapter 3 Notifications and email 3  
 

 

The ability to send information from VISUAL via an email has been expanded and improved.  

Notifications 
When certain business events occur, such as the creation of a customer order or receipt of a 
purchase order, you can now set up VISUAL to automatically send email notifications to the contact 
listed on the sales order or purchase order. You can also send a copy of the notification to 
employees.  

These business events can trigger notifications: 

• A customer order is created 
• A customer order is edited 
• A shipment is sent 
• A shipment is edited 
• A payment for an invoice is created (sent to internal contacts only) 
• A purchase order is created 
• A purchase order is edited 
• A purchase is received 
• A payment for an invoice is created (sent to internal contacts only) 

Creating notification email content 
To create the content of notification emails, use Notification Maintenance. To open Notification 
Maintenance, select Admin > Notification Maintenance. 

You can create separate email content for each application that supports notifications. You can use 
tokens to personalize the content for the recipient. When the email is created, the token is replaced 
with content from your database. For example, you can use the %ContactName token in a 
notification for customer orders. When the email is created, %ContactName is replaced with the 
contact on the order.  
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Internal recipients receive the same email as your customer and vendor contacts. You cannot create 
different email templates for internal and external audiences.  

Triggering notifications 
Use Vendor Maintenance and Customer Maintenance to set up default notification triggers.  

To specify default actions for customers, from Customer Maintenance select Maintain > 
Notifications. You can send email to the order contact when a new order is created, when an order 
is changed, and when an order ships. For employees only, you can also send an email when an 
invoice is created. To specify default actions for vendors, from Vendor Maintenance select Maintain 
> Notifications. You can send email to the order contact when a new order is created, when an 
order is changed, and when an order is received. For employees only, you can also send an email 
when an invoice is created.  

In both Customer Maintenance and Vendor Maintenance, you can also select the employees that 
receive a copy of the notification. To be eligible for selection, an employee must have an email 
address. 

You can override the default settings for customers in Customer Order Entry and for vendors in 
Purchase Order Entry. In these applications, you can also use the Notify Me check box to send 
notifications to the user who created the order. To activate the check box, the ID of the signed in 
user must be specified on an employee record. The employee record must also contain an email 
address.  

Reviewing notifications 
You can review a list of the notifications sent in conjunction with an order in the Notification History 
dialog. You can access this dialog from Customer Order Entry, the Order Management Window, 
Purchase Order Entry, and the Purchase Management Window. Open the order, and then select 
Info > Notification History. The dialog shows information about the notifications sent for the order, 
including the recipient, the sender, and the action that triggered each notification. 

Emailing with SMTP relay 
If you do not have a default email system installed on your computer, you can configure VISUAL to 
send email with an SMTP relay instead. For example, you can use SMTP relay to email information 
from VISUAL with Gmail or Thunderbird. 

To configure VISUAL to use SMTP relay, use the eMail section of Preferences Maintenance.  

When you send an email from VISUAL, a dialog is provided for you to compose and address the 
email. 
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Customer and vendor email contacts 
In the Email Documents dialog in Customer Maintenance and Vendor Maintenance, you now specify 
by site who receives emails.  

Finding more information about Notifications and 
email enhancements 
This table shows where you can find more information about the enhancements described in this 
chapter: 

Enhancement User Guide 

Notifications “Notifications and Email” chapter of the Infor 
VISUAL Concepts and Common Features 
Guide. 

Emailing with SMTP Relay “Notifications and Email” chapter of the Infor 
VISUAL Concepts and Common Features 
Guide. 

Customer and Vendor Email Contacts “Notifications and Email” chapter of the Infor 
VISUAL Concepts and Common Features 
Guide. 
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Chapter 4 Document attachment 
management 4  

 

 

Several enhancements have been made to improve the management of document attachments. 

Documents by site or by tenant 
When you add a document attachment in Document Maintenance, you can specify that the 
document can be used only by a particular site. Specify the site in the Site ID field before you add 
the document. 

If the document can be shared among multiple sites, you can add the document at the tenant level. 
Specify ** Tenant ** in the Site ID field before you add the document. When you add a document at 
the tenant level, all sites can use it by default. You can manage which sites have access to the 
document in the Allowable Sites dialog. In Document Maintenance, select Maintain > Allowable 
Sites to select the sites that can use the document. 

When you create a document attachment for a site-level record in a maintenance window, the 
document is stored at the site level. For example, if you create an attachment in the Customer Order 
Entry window, the attachment is associated with the site that you specified for the order.  

Document storage by site and reference type 
You can set up set up sub-directories for document attachments by site and by reference type. 

After you create the directories on your hard drive, use the Document Folders Maintenance dialog to 
associate the directories with the appropriate site and reference type. To open the Document 
Folders Maintenance dialog, select Maintain > Document Folders.  

You can control access to the Document Folder dialog in Security Maintenance.  

Note: Because you can set up multiple directories for document attachments, the Default Directory 
for Documents field in Application Global Maintenance has been removed.  
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Default reference types 
You can specify the default reference type to use when you create an attachment in a maintenance 
window. For example, you can specify that documents attached to customer orders should be 
created with the Customer reference type.  

You can specify the default reference type by site. To set up the defaults, select Maintain > Default 
Reference Types.  

Document attachments and database conversion 
When you convert your VISUAL database to 9.0.0, a formal association between the attachment and 
the relevant sites is made.  

For single-site databases, existing attachments are associated with the ID of the single site.  

For multi-site databases, existing attachments are processed in these ways: 

• Existing attachments are associated with the tenant. All sites in the database are allowed to use 
existing attachments.  

• For documents attached to part records, a document reference is created for each site 
associated with the part. In 9.0.0, you can no longer attach a document to a part at the tenant 
level.  

• For documents attached to shop resource records, a document reference is created for each site 
associated with the shop resource. You can no longer attach a document to a shop resource at 
the tenant level.  

Finding more information about Document 
attachment management 
This table shows where you can find more information about the enhancements described in this 
chapter: 

Enhancement User Guide 

Document attachment management “Document Maintenance” chapter of the 
Infor VISUAL System-wide User’s Guide. 
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Chapter 5 Other core business feature 
enhancements 5  

 

 

These other enhancements have been made to core business features and functions. 

Audit History dialog 
You can now view the audit history for individual documents directly in the document’s maintenance 
window. 

You can view audit history in these windows: 

• Accounting Window 
• Contact Maintenance 
• Customer Maintenance 
• Customer Order Entry 
• Estimating Window 
• Manufacturing Window 
• Order Management Window 
• Outside Service Maintenance 
• Part Maintenance 
• Project Maintenance 
• Purchase Order Entry 
• Purchase Management Window 
• Requisitions 
• RFQ Entry 
• RMA Entry 
• Shop Resource Maintenance 
• Vendor Maintenance 
• Warehouse Maintenance 

To view audit information, open a document in one of the windows listed above. Then, select Info > 
Audit History. The date, field, new value, and old value are displayed for the document you selected. 
The ID of the user who made the change is also displayed.  
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To show information in the Audit History dialog, you must audit certain tables. The tables depend 
upon the window you are using.  

You can use Security Maintenance to determine which users can view audit information. 

Document Lifecycle 
In the graphical view, if a user does not have security access to view a particular type of transaction 
in the lifecycle viewer, a card with minimal information is displayed for the transaction. 

Chart colors 
The colors used in charts have been updated to match the current Infor SoHo standard. 

Web sites and queries on user toolbars 
You can now set up user toolbar buttons to launch a web page or to run a query that you have 
created in Query Maintenance.  

ISO country codes 
A browse button for country codes has been added to all areas of VISUAL where you create 
addresses. The browse table contains the two-letter ISO code for each country. 

The ISO codes are added to the country browse table during upgrade. You can continue to use 
custom country codes.  

Line item table configuration 
The dialog that you use to configure line item tables has been updated to match the dialog that you 
use to configure browse tables. The dialog is also resizable. 
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Part Description field 
In Part Maintenance, the size of the Part Description field has been increased to 120 characters. 

IBAN field 
Then length of the IBAN field has been increased to 40 characters.  

Recalculating overlapping labor tickets 
If you edit overlapping labor tickets in Labor Ticket Entry, you can now recalculate proration values. 
The ability to create overlapping labor tickets depends upon the system that you use for labor 
reporting. For example, you can create overlapping labor tickets with VISUAL Time & Attendance or 
VISUAL Barcode. 

After you edit labor tickets, you can click the Recalc Proration button to update prorated values. If 
you prorate by hours, then the Hours information is updated. If you prorate by costs, then the 
Multiplier 2 information is updated. After the recalculation is complete, the changes are displayed in 
a dialog.  

Finding more information about other core business 
feature enhancements 
This table shows where you can find more information about the enhancements described in this 
chapter: 

Enhancement User Guide 

Audit History dialog “Audit Maintenance” chapter of the Infor 
VISUAL System Administrator’s Guide. 

Document Lifecycle “Document Lifecycle” chapter of the Infor 
VISUAL Concepts and Common Features 
Guide. 

Web sites and queries on user toolbars “Customizing VISUAL” chapter of the Infor 
VISUAL Concepts and Common Features 
Guide. 
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Enhancement User Guide 

ISO country codes “Application Global Maintenance” chapter of 
the Infor VISUAL System-wide User’s 
Guide. 

Line item table configuration “Fields, Buttons, Menus, and Other Window 
Controls” chapter of the Infor VISUAL 
Concepts and Common Features Guide 

Recalculating overlapping labor tickets “Labor Ticket Entry” chapter of the Infor 
VISUAL Manufacturing User’s Guide. 
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Chapter 6 Dashboard enhancements 6  
 

 

You can now create your own dashboard metrics. Additionally, enhancements have been made to 
the built-in metrics.  

User-defined Dashboard metrics 
You can create custom metrics based on any table, set of tables, or views in the database. After 
your metric is complete, users can add the metric to their dashboards. 

To create a custom metric, you first define a data source. Then, you use the data source to build a 
metric. You can build analytics and detail grids.  

About data sources 
Data sources contain the table columns and database view columns that are used as the basis of 
the metrics that you build. You can use the same data source as the basis of multiple metrics. 

In addition to providing data to your metrics, data sources also determine how end users interact 
with your custom metrics. Use data sources to set up these behaviors: 

• Filters. When you set up the data source, you specify the types of filters that end users can 
apply to the data. For example, you can set up the data source so that it allows users to filter 
information by a customer ID or a part ID.  

• Drill-to links. For detail grids, you can specify the columns that contain clickable links. When 
users click the link, information is opened in the relevant maintenance window. For example, you 
can specify that users can click a part ID to open the part’s record in Part Maintenance.  

• Colors. You can color-code the information in detail grids. You can set up static colors that do 
not change regardless of the data in the grid. You can also set up conditional colors that change 
based on data parameters that you specify. 

Set up data sources in Dashboard. From the Dashboard, select Edit > Edit Data Source. 

To create a data source, you complete these basic steps: 

1 Select the tables or database views to include in the data source. 
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2 If you select more than one table or view, specify how to join them. You join tables and views 
based on a piece of data that is shared between the tables and views, such as customer ID or 
part ID. 

3 As you select tables and columns, a SQL statement is constructed for you. You can test the 
performance of the SQL statement in the Edit Data Source dialog. 

When you are satisfied with your data source, set its status to Active. You can then use the data 
source to construct analytics and detail grids.   

About Analytics 
Use analytics to represent your data in chart form. When you create an analytic, you specify these 
details: 

• Data source of the analytic. The data source determines the information that is available to the 
analytic. 

• Type of analytic. The type of analytic determines how information is measured. You can create 
an analytic that measures values, measures values over time, or identifies the top results for 
parameters that you specify.  

• Chart type. You can select from a variety of charts, including pie charts, bar charts, column 
charts, and line charts. 

• Chart format. You can specify information such as the format of the x- and y-axes and the 
location and position of the legend.  

You can also specify default values that end users can change when the add the analytic to their 
dashboards.  

Create custom analytics in the Dashboard. In the Dashboard, select Edit > Edit Analytic.  

About Detail Grids 
Use detail grids to represent your information in table form. When you create a detail grid, you 
specify these details: 

• Data source of the analytic. The data source determines the information that is available to the 
grid. 

• Type of analytic. The type of analytic determines how information is measured. You can create 
an analytic that shows all data, a top “n” analytic, or a bottom “n” analytic. For top n and bottom n 
analytics, you select the table column that you want to use to evaluate results. You can decide 
whether you are measuring the top or bottom individual values in the table column or the top or 
bottom totals. 

• Chart type. You can select from a variety of charts, including pie charts, bar charts, column 
charts, and line charts. 
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• Chart format. You can specify information such as the format of the x- and y-axes and the 
location and position of the legend.  

• Chart content. You can specify the columns to include in the grid.  

Create custom detail grids in the Dashboard. In the Dashboard, select Edit > Edit Detail Grid. 

Using custom metrics 
After you create a custom metric and set its status to Active, users can add the metric to their 
dashboards.  

When users add custom analytics, they are presented with a dialog that shows the filters that you 
enabled for the analytic in the data source. Any default settings that you specified when you created 
the analytic or detail grid are displayed.  

For value-based custom analytics, users can select the database tables to use for series and 
groupings. For example, if you created an analytic that shows sales order amounts, users could 
decide to group amounts by customer when they add the analytic. Users can also add series to 
certain analytics. A series sub-divides a group. 

Sample content 
Sample custom metric content is provided in the DASHBOARDCONTENT.ZIP file located in your 
VISUAL directory. You can use the samples to examine how data sources are constructed and how 
they are used to create metrics. You cannot edit the original samples, but you can edit copies of the 
samples. 

To use this content, you must first create a view in your database. A script for each database engine 
is provided. 

After you run the script, load the content into the Dashboard. 

1 Select File > Dashboard. 

2 Select Edit > Import Content. 

3 Navigate to the content file for your database engine. 

4 Click Import. 

These sample data sources and metrics are provided: 

Data Source Description Related Metrics 

Infor_Activities  Returns information about 
activities created for customer 
and vendor records. 

Analytic:  
Infor_Activities 
Detail Grid:  
N/A 
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Data Source Description Related Metrics 

Infor_ActivitiesByStartDate  Returns information about 
activities, including when the 
activity was started and when it 
is due.  

Analytic: 
Infor_ActivitiesByPeriod 
Detail Grid:  
N/A 

Infor_BookingsVsShipments  Built on the custom view. 
Returns information about 
booked sales amount and 
shipped amount.  

Analytic:  
Infor_BookingsvsShipments 
Detail Grid:  
N/A 

Infor_CustomerAmount  Returns information about 
customer orders. 

Analytics:  
Infor_CustomerSales 
Infor_TopCustomers 
Detail Grids: 
Infor_BottomCustomers 
Infor_CustomerAmount 
Infor_TopCustomers 

Infor_DeliveryPerformance  Returns information about when 
you shipped orders and when 
customers expected orders to 
be shipped. 

Analytic:  
Infor_DeliveryPerformance 
Detail Grid: 
Infor_DeliveryPerformance 

Infor_PayableHeader  Returns information found on 
the Accounts Payable invoice 
header.  

Analytic:  
Infor_OpenAccountsPayable 
Detail Grid:  
Infor_OpenAccountsPayable 

Infor_ReceivbleHeader  Returns information found on 
the Accounts Receivable 
invoice header. 

Analytic: 
Infor_OpenAccountsReceivab
le 
Detail Grid: 
Infor_OpenAccountsReceivab
le 

Infor_Shipment  Returns information about 
shipments. 

Analytic: 
Infor_Shipment 
Detail Grid: 
N/A 
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Data Source Description Related Metrics 

Infor_ShippingForecast  Returns information about 
anticipated future shipments. 

Analytic: 
Infor_ShippingForecast 
Detail Grid: 
Infor_ShippingForecast 

Infor_Tasks  Returns information about 
tasks. 

Analytic:  
N/A 
Detail Grid:  
N/A 

Infor_VendorAmount  Returns information about 
purchase orders. 

Analytics:  
Infor_TopVendors 
Infor_VendorPurchase 
Detail Grids: 
Infor_BottomVendors 
Infor_TopVendors 
Infor_VendorAmount 

Infor_VendorDeliveryPerfor
mance  

Returns information about when 
you actually received orders 
and when you expected to 
receive orders. It also returns 
information about  

Analytic:  
Infor_VendorDeliveryPerform
ance 
Detail Grid: 
Infor_VendorDeliveryPerform
ance 

Infor_VendorPerformance  Returns information about when 
you actually received order and 
when you expected to receive 
orders. 

Analytic:  
N/A 
Detail Grid:  
N/A 

Infor_WorkOrderCost  Returns information about 
estimated, actual, and projected 
work order costs.  

Analytic:  
Infor_WorkOrderCost 
Detail Grid:  
Infor_WorkOrderCost 
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Other Dashboard enhancements 

Security and the Dashboard 
You can control access to metrics and analytics in Security Maintenance. You can control access to 
both system and custom metrics.  

You can set up access to metrics by profile and by user.  

Work Order Estimated vs. Projected Overall analytic 
The Work Order Estimated vs Projected Overall analytic compares the estimated costs of work 
orders with the projected costs incurred during particular periods of time. 

Date filters on work order metrics 
The date filter is applied to work order want date instead of work order release date in these metrics: 

• Work Order Estimated vs. Projected analytic 
• Work Order Estimated vs. Projected Overall analytic 
• Work Order Estimated vs. Projected detail grid 

Dashboard table windows 
The grids used to display information have been replaced with table windows. This improves 
performance of the dashboard. 

Finding more information about Dashboard 
enhancements 
This table shows where you can find more information about the enhancements described in this 
chapter: 
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Enhancement User Guide 

User-defined Dashboard Metrics “Custom Dashboard Metrics” chapter of the 
Infor VISUAL Concepts and Common 
Features Guide. 

Security and the Dashboard “User Management” chapter of the Infor 
VISUAL System Administrator’s Guide. 

Work Order Estimated vs. Projected Overall 
Date filters in Work Order metrics 
Dashboard table windows 

“Dashboard” chapter of the Infor VISUAL 
Concepts and Common Features Guide. 
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Chapter 7 Leadtime Lifecycle 7  
 

 

You can use the leadtime lifecycle feature to measure your performance from quote to cash. You 
can specify the steps in the process and the projected time each step should take. As you complete 
the steps, the time that each step actually took is compared to the projected time. You can use 
graphs and metrics to analyze your performance compared to the process standards and to identify 
where your processes can be improved.  

Set up leadtime processes in Part Maintenance. 

You can view leadtime information about a particular sale in the Estimating Window, the Customer 
Order Entry window, and the Order Management window. 

You can evaluate the overall performance of leadtime processes in the Dashboard. 

About leadtime processes 
When you create leadtime processes, you can associate steps in your process with these document 
types: 

• Quote 
• Sales Order 
• Work Order 
• Shipment 
• RMA 
• Invoice 
• Payment 

You do not need to include every document type in your processes. For example, if you created a 
process for the sale of in-stock items, you could omit work orders from your process.  

As you work on each step, the start date, end date, and percent complete of the step is updated. To 
update the start date, end date, and percent complete, you can use built-in functionality only, 
SaveProcess macros only, or a combination of the two.  

This table describes the options:  
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Option How it works Notes 

Built-in functionality only Updates the start date, end 
date, actual days, and 
percent complete at pre-
defined stages of the sales 
process, such as releasing a 
sales order, shipping a sales 
order, and creating a 
payment.   

Functions out-of-the-box 
Functionality cannot be 
customized 
Only one process step per 
document type is allowed 

SaveProcess macro only Updates the start date, end 
date, and percent complete 
at stages that you define in 
the macro.  

Multiple steps per document 
type are allowed. For 
example, you can create one 
step for preparing the quote 
and a second step for 
receiving approval from the 
customer. 
Multiple stages in a single 
step is allowed. For example, 
you can use a macro to 
update the quote step 50% 
complete when the quote has 
a status of ready and to 
100% complete when the 
quote has a status of Won. 

Built-in functionality and macros Updates the start date, end 
date, and percent complete 
at pre-defined stages. 
Also updates the start date, 
end date, and percent 
complete at stages that you 
define in the macro. 

Only one process step per 
document type is allowed.  
Multiple stages in a single 
step are allowed. For 
example, you can use a 
macro to update the quote 
step 50% complete when the 
quote has a status of ready. 
When the quote has a status 
of Won or Lost, the built-in 
functionality updates the 
percent complete to 100% 

After you decide whether to use built-in functionality or macros, specify your preference in 
Preferences Maintenance. In the VISUAL Mfg section, locate or add the UpdateProcessActivity 
preference setting. Specify Y to use built-in functionality only or a combination of built-in functionality 
and macros. Specify N to use only macros.  
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Setting up the leadtime lifecycle 
Set up leadtime processes in Part Maintenance. 

To specify the steps in your processes, select Maintain > Process Type. Add the steps in your 
process and specify the number of days each step should take. Processes are defined at the site 
level. 

You can save a process as a template. When you save a process as a template, you must specify 
TEMPLATE as the process type. You can create one template for each site.  

To use a template, click the Process Type browse button and select TEMPLATE. Specify a new 
name in the Process Type field, and then click Save. 

Using a leadtime process 
After you set up a leadtime process, use the Process Type field in the header of the Part 
Maintenance window to specify which process is used for a part.  

The start date, end date, and percent complete of each step in your process is updated 
automatically as you proceed through the sales cycle for the part. You can also manually edit the 
information in the Process Activity dialog that is available in the Customer Order Entry window, the 
Order Management window, and the Estimating window. To access the dialog, select Edit > 
Process Activity. 

Analyzing leadtime processes 
You can use the tools described in this section to analyze your leadtime processes. 

Leadtime Lifecycle 
Use the Leadtime Lifecycle dialog to view the leadtime performance for a particular sales order or 
quote. The dialog shows the overall percent complete of each step in your process and the overall 
percent complete of the entire process: 
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The Leadtime Lifecycle dialog is available on the Info menu in Customer Order Entry, the Order 
Management Window, and the Estimating Window. 

You can customize the colors used in the lifecycle. You can also decide whether to measure the 
overall percentage complete. You can measure the overall percentage by dividing the total number 
of days spent on the process by the total number of days in the process. Or, you can measure the 
overall percentage by dividing the total number of processes completed by the total number of 
processes.  

Leadtime View Panel 
Use the Leadtime View Panel to view information about the leadtime performance for a particular 
sales order or quote. You can view two charts: the Standard vs. Actual (Days) chart and the Percent 
Complete chart. 

The Standard vs. Actual (Days) chart shows a comparison of your actual performance and the 
standards that you specified in the Process Type dialog. 
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The Percent Complete chart shows the percentage complete of each step in the process: 
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Process Activity % Over Std 
This metric is available in the Dashboard. Use this metric to view the percentage of activities that 
exceeded the standards that you specified. The information is grouped in time buckets. You can 
view the metric by processes or by particular steps in the process. You can use this metric to identify 
which processes or which steps in the processes take longer than anticipated. You can also use this 
metric to identify whether your performance is better during certain times of the year. 
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Process Activity Average Performance 
This metric is available in the Dashboard. Use this metric to view the average performance of 
processes. The metric shows the average percentage over or under the standard. The information is 
grouped in time buckets. You can view the metric by processes or by particular steps in the process. 
You can use this metric to identify which processes or which steps in the processes take longer or 
shorter than anticipated. You can also use this metric to identify whether your performance is better 
during certain times of the year. 

Finding more information about Performance 
Leadtime Lifecycle enhancements 
This table shows where you can find more information about the enhancements described in this 
chapter: 
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Enhancement User Guide 

Performance Leadtime  “Performance Leadtime” chapter of the Infor 
VISUAL Sales User’s Guide. 
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Chapter 8 Scheduling and Throughput 
enhancements 8  

 

 

These enhancements have been made in the to help you schedule work orders and analyze 
throughput. 

Scheduler preferences 
You can now set up scheduler preferences by schedule, by site, or by tenant. 

If you are licensed to use multiple sites, you can set up tenant-level, site-level, and schedule-level 
preference settings. When you create a new schedule in a site, the site-level settings are used for 
the default settings for the schedule. If site-level settings are not available, then the tenant-level 
settings are used. You can edit the schedule-level preferences to override the tenant- or site-level 
settings. If you do not create tenant-level, site-level, or schedule-level preferences, then the system 
default settings are used. 

If you are licensed to use a single site, you can set up tenant-level and schedule-level preference 
settings. When you create a new schedule, the tenant-level settings are used for the default settings 
for the schedule. You can edit the schedule-level preferences to override the tenant-level settings. If 
you do not create tenant-level or schedule-level preference settings, then the system default settings 
are used. 

In the Global Scheduler window, users must have system administrator privileges to change 
scheduler preferences. Other users can view the preferences but cannot make changes. 

The SYSADM user can also edit scheduler preferences in Preferences Maintenance. 

Work order scheduling options 
The Sort by Priority, Create Date option has been replaced with the Sort by Priority, Release Date. 
When you select the Sort by Priority, Release Date option, work orders with the highest priority are 
identified. Among work orders with the highest priority, the orders with the earliest release dates are 
scheduled first. 
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Throughput improvements 
These improvements have been made to the Throughput Window: 

• Soft allocation processing. In soft allocations, the pairing of supply to demand is now 
determined separately for each schedule. In earlier versions of VISUAL, the production schedule 
was used to pair supply with sales order demand. These pairings were used for all other 
schedules in a site, which led to an inaccurate analysis of throughput. Since resource capacity 
can vary by schedule, a work order that was available to supply a customer order in the 
production schedule may not be available to supply a customer order in alternate “what if” 
schedules.  

• Soft allocation setup. The Soft Allocation Setup dialog has been expanded to include 
allocation, late by date, work order cost method, and the method to use to measure customer 
service. You no longer need to specify this information each time that you create a throughput 
graph.  

• Time buckets. You can now specify the number of time buckets to include in graphs. You can 
specify a number of monthly, weekly, and daily buckets to display. Specify this information in the 
Soft Allocation Setup dialog.  

• Debug windows. You can choose to display debug windows after soft allocation is complete. 
The Demand window shows customer orders. The Inventory Supply window shows the in-stock 
inventory available to meet demand. The Work Order and Purchase Order supply window shows 
supply orders that are available to meet demand. The Soft Allocations window shows how supply 
was matched to demand.  

• Exceptions report. Exceptions encountered during soft allocation generation are now shown in 
an Exceptions report. To view the report, select File > Exceptions Report in the Throughput 
Window. 

• Streamlined inquiry generation. When you ran an inquiry for the first time in previous versions 
of VISUAL, you selected the options for the inquiry in a separate dialog from the graph dialog. 
The separate inquiry dialog has been removed.  

• Performance improvements. To improve performance, value late, days late, and opportunity 
lost are calculated during soft allocation generation. The information is stored in the 
CUST_ORDER_ALLOC table.  

Unallocated demand and supply in the Customer Service Impact 
Inquiry 
You can now include unfulfilled sales orders and unallocated work orders in the Customer Service 
Impact inquiry. These new check boxes are available in the Customer Service Impact dialog: 

Include COs – Select this check box to include unallocated sales orders in the inquiry. Allocated 
sales orders will also be included.  

COs Only – Select this check box to include only unallocated sales orders in the inquiry. Allocated 
sales orders will not be included. 
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Finding more information about Scheduler and 
Throughput enhancements 
This table shows where you can find more information about the enhancements described in this 
chapter: 

Enhancement User Guide 

Scheduler enhancements  “Concurrent Scheduler and Scheduling 
Window” chapter of the Infor VISUAL 
Manufacturing User’s Guide. 

Work Order scheduling options “Concurrent Scheduler and Scheduling 
Window” chapter of the Infor VISUAL 
Manufacturing User’s Guide. 

Throughput enhancements “Throughput Window” chapter of the Infor 
VISUAL Manufacturing User’s Guide 
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Chapter 9 Shop Floor enhancements 9  
 

 

You can now enter labor tickets and issue materials to work orders directly in the Shop Floor apps. 

Labor transactions 
You can now record labor in the Shop Floor Labor. You can clock in and clock out for the day, clock 
in and out for breaks, and start and stop set up, run, and indirect jobs. For run jobs, you can enter 
the quantity complete, the quantity deviated, and any required trace information. You can view 
documents that are attached to the work order. 

When you select a job to work on, you can see at-a-glance key information about the job, such as 
whether the material required for the job is available, whether the work order is on time, and whether 
any labor tickets have already been recorded. You can use this information to prioritize your work.  

You can use the My Labor page to review the labor tickets that you are currently working on. 

Inventory transactions 
You can now perform these inventory transactions in Shop Floor Inventory Transaction: 

• Adjust in 
• Adjust out 
• Inventory transfer between locations 
• Issue to work order 
• Issue return from work order 
• Receive from work order 

Other inventory transactions, including purchase receipts, purchase returns, shipments, shipment 
returns, interbranch transfers, and physical inventory counts.  

You can scan barcodes into the app.  
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Other Shop Floor enhancements 
These additional enhancements have been introduced: 

• A new icon indicates when a material requirement is a tool or fixture. 
• A new icon indicates when document attachments are available. 

Finding more information about Shop Floor 
This table shows where you can find more information about the enhancements described in this 
chapter: 

Enhancement User Guide 

Shop Floor  Infor VISUAL Shop Floor Installation and 
Configuration Guide 
Context-sensitive help in the Shop Floor app 
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Chapter 10 Material Planning 10  
 

 

These changes have been made in the Material Planning Window. 

Nettable quantity calculation 
Nettable quantity is now calculated consistently in all areas of the Material Planning Window. Parts 
stored in unavailable and transit locations are no longer considered as nettable in Material 
Requirements Planning. 

This calculation is used throughout the Material Planning Window: 

Nettable quantity = the sum of the quantity for all locations in the PART_LOCATION table for the 
part ID, warehouse ID, and Site ID being processed, where the location status is not set to 
Unavailable or the location is not marked ass a Transit location.  

Net using Nettable Quantity 
You can now use the nettable quantity as the starting quantity when netting is initiated in the 
standard and advanced material planning modes. To use the nettable quantity, select View > Net 
Using Nettable Qty. When you generate the Material Planning Report, you can also use the 
nettable quantity as the starting quantity.  

You can also use the available quantity or the on-hand quantity as the starting quantity. 

Suggested Master Production Schedule (MPS) 
calculation 
In the Advanced Material Planning mode, you can now decide whether to calculate suggested MPS. 

To calculate this value, select Options > Calculate Suggested MPS. 
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When you activate the option, two new rows are displayed in the Advance Material Planning window 
and the Master Product Schedule dialog: Suggested MPS and Proposed Inventory. 

The Suggested MPS row is calculated using this formula: 

If Gross Demand > (Beginning Inventory + Current Firmed Orders), then Suggested MPS = 
Gross Demand – (Beginning Inventory + Current Firmed Orders) 

Otherwise, the suggested MPS = 0. 

In the planning period that contains the current date, the safety stock is taken into consideration. 
This formula is used to calculate suggested MPS:  

If Gross Demand > (Beginning Inventory + Current Firmed Orders – Safety Stock), then 
Suggested MPS = Gross Demand – (Beginning Inventory + Current Firmed Orders) 

If the part has minimum order quantity, maximum order quantity, or multiples of values, then these 
values are taken into consideration when calculating suggested MPS. 

The Proposed Inventory row shows the inventory level of the part if you update the MPS for the part 
to match the suggested MPS. This formula is used to calculate proposed inventory: 

Proposed Inventory = (Beginning Inventory + Current Firmed Orders + Suggested MPS) – 
Gross Demand 

In the Master Production Schedule, you can now select Suggested MPS when you copy demand to 
the production schedule.  

The Material Planning Report available in the Advanced mode also uses the Suggested MPS 
calculation and also shows the Proposed Inventory row.  

If you are calculating Suggested MPS, then MRP processing is changed in these ways: 

Current Firmed orders are no longer applied against MPS entries. Current firmed orders are now 
part of the suggested MPS calculation.  

The Net On-Hand for Master Scheduled Parts check box is no longer available.  

Planning Period Details dialog 
The Planning Period Details dialog has been added to the Advanced mode of the Material Planning 
Window. This dialog shows a daily breakdown of the planning period.  

The header shows the totals for the period. The type of demand period is also displayed. The 
demand period type indicates how gross demand values are calculated.  

The first table shows the daily breakdown of the totals shown in the header. You can use the Show 
Active Forecasts check box to add a row for active forecasts.  

The second table shows supply and demand orders for the period. You can view supply and 
demand orders for a particular day or range of days by selecting columns in the first table.  
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To view the dialog, double-click a planning period column header. You can also select the column 
and then select Info > Show Planning Period Details. 

Color in the Advanced mode 
You can now apply color preferences to the Advanced mode. 

To access the Color Preference dialog, select Options > Color Preferences. Select the Apply to 
Advanced Mode check box to apply color to both the standard and advanced modes.  
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Period Want Day in the Master Production Schedule 
and Copy Demand to MPS dialogs 
These enhancements have been introduced: 

• When a value is specified in the Period Want Day field in the Master Production Schedule and 
Copy Demand to MPS dialogs, the value is retained when you close and re-open the dialog  

• You cannot enter a value less than one or greater than any of the values in the planning 
calendar  

Period column headers in Advanced mode 
You can now display the first day of the period as the period column header. To use the first day of 
the period as the column header, select View > Show First Day of Period. 

Finding more information about Material Planning 
This table shows where you can find more information about the enhancements described in this 
chapter: 

Enhancement User Guide 

Material Planning  “Material Planning Window” chapter in the 
Infor VISUAL Inventory User’s Guide. 
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Chapter 11 Utilities and Administration 11  
 

 

AutoRun 
This section describes the changes made to VISUAL’s AutoRun functions. 

DBR Scheduler Service 
You can now run the DBR Scheduler with the DRB Scheduler Service. You can use the Scheduling 
Service to run the DBR Scheduler automatically on the days and times you specify. If you have 
multiple sites and would like to run the service for all sites, then you must install the service once for 
each site.  

To specify when to run the service, use the Set as Scheduled dialog in the DRB Scheduler. You can 
use the service to run the DBR Scheduler up to six times a day. You also specify the standard 
settings to use to run the schedule, such as the sort order and how to schedule started work orders. 

You can set up one run schedule for each schedule ID in the DBR Scheduler window. Any user that 
has access to the Set as Scheduled dialog in the DBR Scheduler window can edit the run schedule 
for a schedule ID. The system administrator can control which users have access to the Set as 
Scheduled dialog.  

After the service is installed and the service schedule is set up, the database is examined based on 
the polling interval that you specify to see if a schedule needs to be run. When the service finds a 
schedule that needs to be run, the service opens the DBR Scheduler and runs the schedule based 
on the settings you specify in the Set as Scheduled dialog.  

If you set up the DBR Scheduling Service, you can still run the DBR Scheduler manually. 

Coordinating MRP and Scheduling services 
Since material requirements planning and scheduling can be dependent upon each other, you can 
set up the schedules for these services to ensure that each runs only when the other is not running. 
When you set up the MRP service schedule, select the Delay for Scheduling check box to ensure 
that MRP is not run while scheduling is being run. When you set up the Scheduling service 
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schedule, select the Delay for MRP check box to ensure that Scheduling is not run while MRP is 
being run. 

Polling interval 
The maximum polling interval is now 900 seconds for all Auto Run services.  

MRP AutoRun configurations 
You can now set up separate schedules for regeneration and net change. 

Query Tool updates 
The Query Tool has been updated to help you join tables in a query. 

When you double-click a table, the table is added to the Join Tables grid. When you highlight a table 
in the Join Tables grid, tables that have a foreign key relationship to the table are displayed in the 
Database Tables and Column section. The column that the tables share in common is displayed in 
parenthesis.  If a table name is displayed in red, then the table contains a foreign key reference to 
the tables in the Join Tables grid. If a table name is displayed in blue, then the table in the Join 
Tables grid contains a foreign key reference to the table displayed in blue.  

As you add tables to the Join Tables grid, the join statement is written automatically. By default, an 
inner join is created. You can use a left outer join or no join instead.  

If you have custom database tables, you can use the Extra Joins table to identify additional foreign 
key relationships in your database.   

After you save a query, you can add the query to a user toolbar in the Query Tool window. When 
you return to the Query Tool window, you can re-run the query by clicking the toolbar button. To add 
a query to a toolbar, select File > Add User Toolbar. 

You can also add the query to a user toolbar that you use in other windows in VISUAL. Use Toolbar 
Maintenance to add the query. When you run a query from a toolbar in any window other than the 
Query Tool window, the new Query Runner (VMQRYRUN) executable is used to run the query. 

Security and user management 
In the Users dialog, the list of users in your database is now presented in a table. You can see all 
users in your database. 
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The columns that are included in the Users dialog depends upon your license. If you use a named 
user license for VISUAL and also have VISUAL CRM, then a column is displayed for CRM. You can 
use this column to add users that have access to CRM only. 

If you are licensed to use VISUAL Mobile Labor or VISUAL Mobile Material, then columns are 
displayed for those applications. You can assign users to the mobile apps without consuming a 
VISUAL user.  

These settings have been added to Security Maintenance: 

• Dashboard security. You can restrict user access to system and custom metrics. You can 
restrict access by user or by profile. 

• Query security. You can restrict user access to queries that have been created in the Query 
Tool. You can restrict access by user or by profile.  

Audit History dialog. You can restrict user access to the Audit History dialog. This setting has been 
added to the Program Component settings on each executable that supports the Audit History 
dialog. You can restrict access by user or by profile. 

Default preference settings in Preferences 
Maintenance 
The system administrator can now set up default preferences that are applied to all VISUAL users. 

When the system administrator sets up default preferences, the system administrator can specify 
that a preference is global. A global preference is a required preference. Individual users cannot 
override a global preference setting. When individual users set up preferences, required preference 
settings are displayed in red. 

If the system administrator specifies that a default preference is not a global preference, then 
individual users can specify a different value for the preference setting. If an individual user specifies 
a different value than the default value, then the value is displayed in blue. 

Display License dialog 
In the Display License dialog, the names of the products and modules have been updated to better 
reflect their functionality. 
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Finding more information about utilities and 
administration enhancements 
This table shows where you can find more information about the enhancements described in this 
chapter: 

Enhancement User Guide 

AutoRun updates “VISUAL AutoRun Services” chapter in the 
Infor VISUAL System Administrator’s Guide. 

Query Tool updates “Query Tool” chapter in the Infor VISUAL 
Concepts and Common Features Guide. 

Security and user management “User Management” chapter in the Infor 
VISUAL System Administrator’s Guide. 

Default preference settings in Preferences 
Maintenance 

“Customizing VISUAL” chapter in the Infor 
VISUAL System Administrator’s Guide. 

Display License dialog “Set Up and Maintenance” chapter of the 
Infor VISUAL System Administrator’s Guide. 
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Estimating enhancements 
These enhancements were made to estimating functions. 

Import Quick Quote from spreadsheet 
When you use Quick Quote to prepare an estimate, you can now import information from a Microsoft 
Excel spreadsheet.  

To import a spreadsheet, click the Copy From button in the Quick Quote dialog. Click the Excel 
option, and then specify the spreadsheet to import.  

To successfully import the spreadsheet, it must meet these criteria: 

• The spreadsheet must have columns for W/O Sub ID, Part ID, Seq No, and Piece No. 
• The quote cannot contain legs.  
• The spelling and case of the columns in the spreadsheet must match the spelling and the case 

of columns used in VISUAL. 

To ensure that the spreadsheet columns are formatted correctly, you can send an existing Quick 
Quote to Excel. Edit the spreadsheet for the new quote, and then use the Copy From function to 
import the spreadsheet into VISUAL.  

After you import the spreadsheet, it is attached to the quote as a document attachment. 

After you create a Quick Quote using an Excel spreadsheet, you can edit the information in the 
Quick Quote dialog. To review the original information imported from the spreadsheet, click the View 
ExcelData button. A grid that contains the imported information is displayed. 

Bid rate groups and categories 
You can now set up bid rate categories and organize them into groups. You can use bid categories 
and groups to analyze your quoting processes. You can compare the budgets that you set up in 
quotes to the actual costs of manufacturing a product.  
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To set up bid groups and categories, use Application Global Maintenance. 

After you set up categories, you can assign them to shop resources and parts.  

When you create a Quick Quote in the Estimating Window, the bid categories associated with the 
resources and materials are displayed. You can export the quote information to Excel for further 
analysis. 

Vendor price breaks on quotes that use costs from parts   
If you use the Part record as the source of the cost on a quote, you can now apply vendor price 
breaks when you calculate the quote price. The price breaks offered to you by the preferred vendor 
for the part are used. If you do not use vendor price breaks when you calculate the quote price, then 
the costs specified for the part on the Costs tab in Part Maintenance are used to calculate the quote 
price.  

Estimating Window right-click menu 
The Material Planning Window has been added to the right-click menu. 

RMA enhancements 
These enhancements have been introduced to RMA processing. 

• Reuse or copy evaluation work order for repair work order. When you convert an evaluation 
RMA to a repair RMA, you are given the option of copying or reusing the work order that you 
created for the evaluation.  

• Use a different customer to process an RMA. You can now send repaired or replacement 
parts to a different customer from the customer who returned the part. You can also credit a 
different customer for a return. 

• Line numbering. When you create a new customer order to process an RMA, you can now use 
the next number available for the customer order line instead of copying the line number from the 
original customer order.  

• Shipping repairs on customer orders. When you process a repair RMA, you can now include 
more than one RMA on the same customer order. When you ship the customer order, you now 
select the RMA for the shipment at the line level. The RMA field in the Shipping Entry header has 
been removed.  

• Pre-assigning returned quantities to work orders. If an order has multiple supply links, it can 
be difficult for the individual who process the return receipt to determine how the return should 
be assigned to the supply. To remove the guesswork, you can now pre-assign the returned 
quantities to supply when you create the RMA.  
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• Contact for RMA. You can specify a contact for the RMA. By default, the contact from the 
customer order is used, but you can select a different contact. 

• User-defined fields. The standard user-defined fields have been added to the RMA header and 
RMA line item table.  

• RMA Acknowledgement report. You can now generate an RMA Acknowledgement report. You 
can send the acknowledgement to your customer to confirm that you have created an RMA for 
the customer’s return.  

• RMA Preferences. To streamline data entry in the RMA Entry window, you can set up 
preferences that set default values and suppress dialogs. Specify preferences in Preferences 
Maintenance. 

• RMA in the Document Lifecycle. In both the Graphical view and Table view, you can now view 
the status of the RMA. 

Emailing customer invoices 
In Invoice Forms, you can now email invoices directly to customers.  

Setting up 
To set up the emailing of invoices, complete these tasks: 

• In Document Maintenance, specify where to store the invoices that you generate. You can 
create a directory specifically for invoices in each site.  

• In Notification Maintenance, specify the content of the email message. Use the Email AR 
Invoices tab to specify this information. 

• In Customer Maintenance, specify which customers and contacts receive emailed invoices. 
Specify this information by site. To specify that a customer receives emails, select the Email 
Invoices check box on the Order Mgt tab. To select the contacts that receive emails, use the 
Email Documents dialog. For each site and contact, select the Customer Inv check box if the 
contact receives invoices by email for the site.  

Emailing invoices 
After you generate invoices in Invoice Forms, use the Email Invoices dialog to email the invoices. 
Select File > Email Invoices to access the dialog. In the dialog, you can view a list of invoices that 
are eligible to be emailed. Select the invoices to email, and then click Run. You can also print 
invoices from the Email Invoices dialog. 

The Email Invoices dialog has also been added to the Progress Billing and Project Billing windows.  
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In Accounts Receivable Invoices, you can view information about how an invoice was emailed to a 
customer on the Distribution tab.  

Consolidated customer orders 
When you create a customer order, you can now specify sites at the line level. The sites that you 
select for lines must share the same parent entity as the site specified on the order header.   

You cannot use this functionality if you generated the order from a quote.  

Price Book 
Price group has been added as a context to VISUAL Price Book. You can specify price groups and 
assign them to parts in Part Maintenance. 

When you sign into the VPB database after you install VISUAL 9.0.0, you are prompted to upgrade 
your database.  

Specify the VPB user ID and password for both the Owner credentials and the Admin credentials. 

Product Cost and Gross Profit view panel 
In Customer Order Entry and the Order Management Window, you can now view production cost 
and gross profit for the entire order.  

To display this analytic, select View > Production Cost and Gross Profit. 
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Use this chart to evaluate the accuracy of your cost estimates and the profitability of your customer 
pricing structure. 

All amounts are shown in the functional currency of the parent accounting entity for the site specified 
in the order header.  

The chart has two lines: Sell Price and Profit. The Sell Price line shows the extended price of the 
customer order line. The profit line is calculated by subtracting the projected costs from the sell line.  

The chart also has three bars: Estimated Costs, Actual Costs, and Projected Costs.  

The Estimated Costs bar shows the estimated cost to produce the quantity on the order line. If the 
customer order line is linked to a work order, then the work order is used to calculate estimated 
costs. If the customer order line is not linked to a work order, then the standard costs specified on 
the part record for the site are used.  

The Actual Costs bar shows the actual costs incurred for any shipped quantities. If the customer 
order line is linked to a work order, then the actual costs from the work order are used. If the 
customer order line is not linked to a work order, then the actual cost layers for shipped quantities 
are used to calculate this bar. 
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The Projected Costs bar shows the projected total costs to produce the quantity on the line. 
Projected costs are calculated by adding the actual costs for any shipped quantities to the estimated 
costs for any unshipped quantities. If the customer order line is linked to a work order, then the work 
order is used to calculate the actual and estimated costs. If the customer order line is not linked to a 
work order, then the actual cost layer for the shipment is used for the actual costs, and any 
remaining quantity is calculated using the part standard.  

Click any bar or line to view information about linked work orders or part standard costs. This 
information is displayed for all quantities: supply qty, shipped qty, estimated costs, actual costs, 
projected costs, sell price, estimated gross profit, projected gross profit, gross profit difference, and 
unit of measure. The functional currency used to express the values is also displayed. For work 
orders, the ID, want date, status, scheduled start date, and scheduled finish date are also displayed. 

Finding more information about sales enhancements 
This table shows where you can find more information about the enhancements described in this 
chapter: 

Enhancement User Guide 

Estimating enhancements “Estimating Window” chapter in the Infor 
VISUAL Sales User’s Guide. 

RMA enhancements “Return Material Authorization” chapter in 
the Infor VISUAL Sales User’s Guide. 

Emailing customer invoices “Customer Maintenance” and “Invoice 
Forms” chapters in the Infor VISUAL Sales 
User’s Guide. 

Consolidated customer orders “Purchasing and Sales in a Multi-site 
Environment” chapter in the Infor VISUAL 
Multi-entity and Multi-site User’s Guide. 

Price Book “Price Book” chapter in the Infor VISUAL 
Sales User’s Guide. 

Product Cost and Gross Profit view panel “Customer Order Entry” chapter in the Infor 
VISUAL Sales User’s Guide. 



  

Infor VISUAL 9.0.0 Release Notes | 63 

Chapter 13 Procurement enhancements 
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Drill-down buttons in Receiving Inspection 
You can now use drill-down buttons to drill to more information about parts, purchase receipts and 
vendors directly from the Receiving Inspection window.  

Outside Service Maintenance customizable user-
defined fields 
You can now add customizable user-defined fields in Outside Service Maintenance. 

Finding more information about procurement 
enhancements 
This table shows where you can find more information about the enhancements described in this 
chapter: 

Enhancement User Guide 

Drill-down buttons in Receiving Inspection “Fields, Buttons, Menus, and Other Window 
Controls” chapter in the Infor VISUAL 
Concepts and Common Features Guide. 

Outside Service Maintenance customizable user-
defined fields 

“Customizing VISUAL” chapter in the Infor 
VISUAL System Administrator’s Guide. 
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Viewing information by account group in the 
Accounting Window 
You can now view information in the Accounting Window by account group.  

If the account group contains income statement accounts, you can view a line chart that compares 
year-to-date balance and year-to-date budget amounts. 

When you set up account groups, you decide whether equity, liability, and revenue accounts are 
considered to be positive or negative values.  

Single transaction batches 
You can now create a separate batch for each transaction when you post financial transactions to 
the General Ledger. Use the Create Financial Batches with Only One Transaction check box on the 
Defaults tab in Accounting Entity Maintenance to specify which entities use single transaction 
batches. To remind you that multiple batches will be generated, a One Tx per Batch check box is 
displayed on the Post Distributions to General Ledger dialog. This check box cannot be edited; it is 
only displayed if the Create Financial Batches with Only One Transaction check box is selected in 
Accounting Entity Maintenance.  

When you view the G/L Transactions report before or after posting the transactions, all batches 
created during processing are displayed in the report.  

The View Batch dialog has been added to the Accounts Payable Invoice Entry, Accounts Payable 
Payment Entry, Accounts Receivable Invoice Entry, Accounts Receivable Cash Application, and 
Cash Book windows. In the View Batch Information dialog, this information has been added: 

• Batch Posting Date 
• Batch Create Date 
• Batch Posted By 
• Batch Locked 
• Dist Posting Date 
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• Dist Create Date 
• Dist Created By 

VAT transactions 
Updates have been made to allow local VAT charges to be applied to goods that are imported 
between two countries that use the Euro.  

Exporting the Recalculate Standard Costs table to 
Microsoft Excel 
You can export the contents of the table in the Recalculate Standard Costs dialog to Microsoft Excel. 
Click the Send to Microsoft Excel button. 

Commercial WIP Balance summary report in project 
databases 
You can now print a summary version of the WIP balance report for commercial work orders. Print 
this report in the Post Manufacturing Journals window. 

Finding more information about accounting 
enhancements 
This table shows where you can find more information about the enhancements described in this 
chapter: 

Enhancement User Guide 

Viewing information by account group in the 
Accounting Window 

“Accounting Window” chapter in the Infor 
VISUAL General Ledger User’s Guide. 

VAT Transactions “Accounting Entity Maintenance” chapter in 
the Infor VISUAL System-wide User’s 
Guide. 
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Enhancement User Guide 

Exporting the Recalculate Standard Costs table to 
Microsoft Excel 

“Manufacturing Costing” chapter in the Infor 
VISUAL System-wide User’s Guide. 

Commercial WIP Balance summary report in 
Project databases 

“Post Manufacturing Journal” chapter in the 
Infor VISUAL General Ledger User’s Guide. 
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These enhancements are available for users who use VISUAL in conjunction with VISUAL for .NET 
applications. 

Direct updates to .NET VISUAL tables 
If you use VISUAL .NET, changes that you make in standard VISUAL are now made to the .NET 
tables directly instead of through the VISUAL Exchange Service.  

Changes made to this information in VISUAL are directly updated in VISUAL Time & Attendance: 

• Labor Tickets 
• Indirect IDs 
• Shop Resources 
• Departments 
• Shifts 
• Deviation Reasons 
• Countries 
• States 
• Employees 
• Earning Types 

Changes made to this information in VISUAL are directly updated in VISUAL Global Financials: 

• Countries 
• States 
• Employees 
• Earning Types 

After you upgrade your VISUAL database to 9.0.0, perform these tasks to activate direct updates: 

• In VISUAL, select Admin > Application Global Maintenance. Select Maintain > VISUAL .NET 
Configuration. Ensure that the instance group, instance name, and VISUAL .NET install path 
are correct. If they are not correct, then review your database topology in VISUAL .NET to 
ensure that the VISUAL manufacturing database is properly registered. 
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• In the VISUAL executable directory, run VMVXCTGR.exe to remove the triggers and stored 
procedures used with VISUAL Exchange.  

Global Financials and the Document Lifecycle 
viewer 
If you use VISUAL for .NET Global Financials, you can now view Accounts Payable and Accounts 
Receivable invoices and memos in the document lifecycle. You can drill directly into Global 
Financials from the lifecycle viewer. 

Finding more information about accounting 
enhancements 
This table shows where you can find more information about the enhancements described in this 
chapter: 

Enhancement User Guide 

Direct updates to .NET VISUAL tables “Application Global Maintenance” chapter in 
the Infor VISUAL System-wide User’s 
Guide. 

Global Financials and the Document Lifecycle 
viewer 

“Document Lifecycle” chapter in the Infor 
VISUAL Concepts and Common Features 
Guide. 
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